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EVIO EVENT VIEWING

1. Evio Event Viewing

This manual describes a graphical user interface for looking at EVIO format files event-by-event,
although it can also look at any file as a list of 32 bit integer (words). To run it simply execute:

java org.jlab.coda.eventViewer.EventTreeFrame

Make sure that the EventTreeFrame class or the jar file JEventViewer-1.x.jar in is your
CLASSPATH environment variable. The following is a screen shot of the gui.

Figure 1.1: Event-viewing gui
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1.1 Features
Here’s a quick list of the main features:

e Valid event sources are files, cMsg messages, and ET buffers
e Fast compare ability for data from different events

e When receiving events through cMsg or ET, they can be filtered based on their CODA event
type (physics, control, etc.) and trigger type if physics event

e View integer data as hex or decimal

e Select dictionary from event source or from separate file containing dictionary
e View the dictionary being used

e Export any evio file in xml format

e Add or remove data columns

e View the contents of any file as 32 bit hex integers and search for values, evio structures, or
evio errors

Starting with the middle of the gui first, the left side shows a tree structure diagram of the whole,
single evio event being viewed. Notice that the type of each evio structure is given (bank, segment,
tagsegment), along with the type of data it contains, tag, num, size, and # of children. Tag and num
are shown in decimal and hex. If a dictionary is being used, the dictionary name is displayed instead
of the corresponding structure type, data type, tag, and num values.

The right side, on the other hand, shows the data of any selected bank, segment, or tagsegment that
contains a primitive data type. The number of columns can be set in the “View” menu. Integers can be
displayed in hex or decimal.

A fast compare feature is able to compare data from different events. If the current event is changed
while viewing the data of its selected structure, and if the new event has a structure with the same
hierarchy of tags that the previous selection had, it too is automatically selected. This facilitates
comparing the same structure in each successive event by simply hitting the “next” event button.

A dictionary can be loaded from a separate xml format file, or it can come embedded in an evio
format file or buffer (cMsg, ET). The viewer allows the user to switch, in the “Dict” menu, between
the different dictionaries if more than one is available. Any dictionary being used can be displayed
instead of the data.

Selecting an ET system or a cMsg server as an event source, in the “Event” menu, brings up other
menus to allow the proper connections to be created and maintained. The only assumptions made are
that in a cMsg message, the evio data is contained in the byteArray field. Any dictionary is first
looked for in the evio data and if none is found, it is looked for in a String payload item called
“dictionary”.

The box in the upper left (under the row of menu buttons), “Event #”, shows the event currently
selected (in this case 25) and allows the user to navigate to the desired event.
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The box to its right, “Event Q”, shows different things depending on if the data source is a file, cMsg
message, or ET event. For files it shows the total number of events (in this case 10,000). For cMsg
messages and ET events, on the other hand, events are continually arriving. In this case, “Size” shows
the number of events currently in an internal queue. “Limit” allows the user to set the size of this
internal queue, while “Clear” will remove all events currently in the queue. Once this queue is full,
nothing else is added. The “Event #” controls can be used to switch between events in the queue.

Switching between the different event sources can be done in the “Event” menu item. When selecting
a cMsg or ET source, the “Filter” menu is enabled. With this menu, the user can choose to look at
control, partially-built physics, physics events, or any combination as well as the selecting the run
type of interest.

Notice that above the data, there are boxes containing the event and dictionary sources. Beneath the
data are boxes containing information about the selected data structure.
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2. File Data Viewing

The following figure is a screen shot of a particular file’s data obtained by selecting the
“View File Bytes” option of the “File” menu of the initial screen shown previously.

Figure 2.1: Data-viewing gui

_rawdata 001716 000.evio bytes

File
fhome/timmer/ evioTestFiles/hd_rawdata_001716_000.evio
s hE Word Fosition +1 +2 +3 +4 +5 Comments >
DD 0| 0x0000000d] _ 0%00000000] _ 0x0000000B| __ 0x0000000L] __ 0x00000000 -
) Word Value 5 0x00000004] 0x00000000 0x%c0da0100 0x00000004, 0xTTd10100] 8lock Header|=
10 0x54816at1, 0x000006b4 0%00000001 0x000023bd 0%00000001
J Word Position 15 000000008 000000003 0%00000000 0x00000004, 0x00000000
20 0XC0da0100] 0%00000004 0%TTd20100 0x54816atd 0x00000000] _ Block Header
) Page Scrolling 25 0x00000000) 0x000092eh 0xTT701001 0x00000023, 0xTT232033
_ 30 0x000a0006, 0x00000000 0x00000001 0x00000000, 0xh84has25
® Evio Block 35/ 0x000006b4| 000000001 000850001  0x00010000[  0x38010002
O Evio Event 40 0xhg4has25, 000000000 0%35010002 0xb94haB25 0%00000000
= 45 0%38010002 0xhg4haszs 0%00000000 0%37010002 0xhg4hag25
) [ [Erh 50 0x00000000, 0x40010002 0xb54haBz5 0x00000000, 0x34010002
- 55 0xb54has25, 0x00000000 032010002 0xb54haBz5, 0x00000000
&0 0%33010002, 0xb94bas25 0%00000000 0x3T010002, 0xbg4bas25
I Search For ] 55 0x00000000 0%3a010002 0xb94haBs25 0x00000000) 0%39010002
H 0xc0da0100 | - H 70 0xh54has25, 0%00000000 0%3d010002 0xb54haB25 0%00000000

75 0x3h010002] 0xh94ha825 0x00000000 0x3c010002] 0xhS4ha825
80 0x00000000| 0x47010002 0xh94haB25 0x00000000| 0x4e010002
‘ 85 0xb94baB25] 0x00000000 0x4d010002 0xbh94bag25| 0x00000000

Search Controls

‘ = ” z 90| 0x52010002]  Oxh94baszs 0%00000000]  0x01010002 0xhg4has2e
‘ Stop | 95 0x00000000|  0x49010002 0xb94baBz5  0x00000000 0%1c010002
100]  0xbS4bag25]  0x00000000 0x5e010002] _ 0xh94bagas 0x00000000

‘ Done | 105  0x4p010002)  0xbddhaszs 0x00000000]  0x57010002 0xh84has25
110]  0x00000000[  0x19010002 0xb94baB25|  0x00000000 0%1a010002

o B0 115 0xb94bag25|  0x00000000 0x1b010002]  0xh94pagas 0%00000000

120 0x0 010002 0xh94ha825 0x00000000 0x0e010002] 0xh94ha825
125 0x00000000| 0x0d010002 0xh94baB2s 0x00000000)| 0x0c010002

| >

) Block # 52422

) Block # 52423 130) 0xbG4has25 0x00000000 0x0k010002 0xb34bag25, 0x00000000
135 0%14010002, 0xb94bag25 0%00000000 0x15010002, 0xb94bag25

5t 7 B2 140 0x00000000) 0x16010002 0xb34baB25s 0x00000000)] 0x13010002
) Event #1719 145 0xb34bag25, 0x00000000 0x12010002 0x094baB25 0x00000000
) Event #1723 || 150 0x110100032, 0xb34bagz5s 0x00000000 0x10010002, 0xb34bag25
= 155 0x00000000) 0x20010002 0xb34baB25 0x00000000) 0%21010002

1 Event #1724 160) 0xb34baB25 0x00000000 0x22010002 0xb94bag25 0%00000000
) Event #9032 165 0%23010002 0xh34has25 0X00000000 0x24010002, 0xb34hag2s

170 000000000 0x29010002 0xh94haB2s 0x00000000)| 0x25010002
175 0xh94haB25] 0x00000000 0x2a010002 0xh94haB25] 0x00000000
180 0x26010002] 0xb94baB25 0x00000000 0x28010002] 0xb94baB25

) Event #13785

il

Block Info 185 0x00000000 0%27010002 0xb94haB25 0x00000000 0x1T010002
Total words  [58301 190 0xh34hag25 0x00000000 0X00000077 0x00361001 0X00000075
Header words |8 195 0x00120101 0x80d00101 0x80c00001 0x98297503 0x00000017
1] G n 200) 0xc4015007 0xbc8hS544 0xhcBhSa83 0x88c00008 0x 800000

205 0xfBc00000)| 0x81100101 0x91000001 0x98297503] 0x00000017
210 0xc4015007] 0x89000006 0x 9000000 0x 9000000 0x81500101

Event count El

Version u 215 0x91400001]  0x98297503 0x00000017]  0xc4015007 Oxbca35902
Has dictionary [false 220]  0xT94000ed]  0x89400008 0x81900101]  0x81800001 0x98297503
Is last False 225 0x00000017]  0xcd015007 0x85800006] __ 0x 9800000 0xT9800000

230 0x81d00101]  0x91c00001 0%98297503]  0x00000017 0%c4015007

235 Oxbcaf350d| Oxbcafs99d 0x89c00008 0x82100101] 0x92000001
240 0x98297503] 0x00000017 0xc4015007 Oxhcad5shc OxhcadsEec
245 Oxbcad5hd3] 0xTa0000ed 0x8a00000a 0x 2000000 0xTa000000
230 0x82500101] 0x92400001 0x98297503 0x00000017| 0xc4015007
255 OxbcBb525h| OxbcBbSha7 0xbcBhE584 OxbcBbEalal 0x8a400003)
260 0xTa400000)| 0xTa400000 0x82900101 0x92800001] 0x98297503
265 0x00000017| 0xc4015007 0x8aB00006 0x Ta800000)| 0xTa800000
270 083500101 0x53400001 098297503 0x00000017] 0xc4015007

75 Oxhra850fc Oxhead 5507 OxhradS37h 0 Fhat0ed 0xBhADNO0A

4]
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There are occasions when one wants to examine the raw bytes in a file. This tool will
allow one to do just that. Each cell of the table contains 32 bits worth of data displayed in
hex. Data can be switched between big and little endian under the “File” menu. The table
contains 200MB worth of data at one time. For larger files, the next or previous 200MB
are loaded when required while scanning through it. On the very far right of the gui is a
slider which indicates where the current view is in relation to the total length of the file.

2.1 Searching

In order to facilitate finding the data of interest, there are a number of different ways to
hunt through it. The control panel on the left has “Search By” radio buttons allowing one
to select whether to search by:

Looking for a given value

Jumping to a given position in the file

Scrolling page by page

Jumping from one evio block header to the next
Jumping from one evio event to the next
Scanning the whole file for evio faults or errors

ok wdE

2.1.1 By Value

Look for a given value by selecting the “Word Value” radio button, typing the value into
the “Search For” widget, and then hit the forward or backward search button under
“Search Controls”. The “Stop” button will be activated since searching a large file (say
20GB) may take serious time. If a search is stopped, the view position stays where it was
when the search was started. If stopped, starting another search starts from the same
location. A progress bar is there to estimate how much of the file has been searched.

When a value is found, it is highlighted in red. Hit the search button again to find the next
or previous value. Highlights can be cleared under the “File” menu.

2.1.2 By Location

Look at a given location in the file by selecting the “Word Position” button, typing the
position into the “Search For” widget, and then hitting the “Go” button. The view jumps
to the given location and the value is selected (but not highlighted). The first position
starts at 1, not 0. You can read the position from the table by taking the number in the far
left column and adding the number of the heading at the very top of the column.

2.1.3 By Page

The “Page Scrolling” button activates the forward and backward buttons which hop
through the file view by view.
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2.1.4 By Evio Block Header

Look for an evio format block header by selecting the “Evio Block™ button. The program
first looks for the last word — the magic # 0xc0da0100 - of an evio block header. If found,
it checks that the previous word is 0 and the one before that has the least significant 8 bits
equal to 4 (the evio version). If so, it highlights all 8 words in orange. All the information
contained in that header is also displayed on the left in a panel called “Block Info” which
can be seen in the figure above.

This type of searching is useful when dealing with corrupted data files as it can home in
on an area of the file whose format can be checked and can give information about what
data should come following. Hint, if no block header is found in a scan, switch the data

endianness and try another one.

2.1.5 By Evio Event

Look for an evio event by selecting the “Evio Event” button. This is less straightforward
than looking for block headers since there is no universal signature to look for. There are
two ways to do the search. The first way is start the search immediately upon loading the
file’s data or to first select the “0” position (far left column before any data). Then hit the
forward button. It is smart enough to hop over any block header encountered and uses the
length found in the event’s header to be able to find the next when the forward button is
clicked again. The first word of each event found in this way is highlighted in blue and
the header information is displayed on the left in a panel called “Event Info” (see figure
below).

Event Info ————
Length D
Tag
Num o]
Type
Data type
Padding D

2.2 Event information panel

The second way to search is to select the known first word of an event with the mouse.
Hit the forward button to find subsequent events. Hint, the word immediately after a
block header is the first word of an event.

2.1.6 By Evio Faults

Look for faults or errors in the evio format by selecting the “Evio Fault” button. This
program scans the file from beginning to end and lists any errors in a panel to the left
called “Evio Errors” (which can be seen in figure 2.1). The algorithm used to find these
errors assumes that if a block header length does not equal the sum of the lengths of all
the events it contains, then the block header is correct and the events are in error. It tries
to continue scanning for the next error and stops if it encounters an unrecoverable error or
makes it to the end of the file.
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The errors come in two varieties: block and event. All blocks in which there are problems
are listed as are any events in which errors are found. These errors are listed as buttons.
Click one and it hops to the location of the error with either the first block or event word
selected. Its corresponding error message is also displayed at the top of the gui (not
pictured).




